Delayed Email Alerts

Incident Report for Dead Man's Snitch

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 15:18 EDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 15:18 EDT

Update

We've worked through the backlog of email alerts as Amazon SES has recovered for us. We are still monitoring the situation as AWS continues to work through issues with multiple services.
Posted Oct 20, 2025 - 14:06 EDT

Monitoring

Email alerts are currently backed up due to upstream issues with our service provider (Amazon SES). Integrations (such as Slack and Webhooks) are unaffected though depend on the state of those services.
Posted Oct 20, 2025 - 13:19 EDT
This incident affected: Email Alerts.