Delayed Email Alerts
Incident Report for Dead Man's Snitch
Resolved
This incident has been resolved.
Posted Oct 15, 2020 - 11:36 EDT
Investigating
We're investigating an issue with a blocked worker queue that has caused some alerts to be delayed and some by several hours. Our workers have caught up and we're monitoring the situation. We're continuing to investigate the impact and root cause.
Posted Oct 15, 2020 - 10:32 EDT
This incident affected: Email Alerts.