Email Check-Ins not being received
Incident Report for Dead Man's Snitch
Resolved
Email check-ins are back to normal levels. We're looking into why inbound servers didn't retry with our alternate server and ways to avoid this situation in the future.
Posted Dec 07, 2021 - 13:13 EST
Update
We've updated our inbound email servers in DNS to deprioritize inbound-smtp.us-east-1.amazonaws.com. Email receiving should start to recover as servers receive the new MX record and retry pending emails.
Posted Dec 07, 2021 - 12:23 EST
Identified
Email check-ins for Snitches are currently returning "451 Temporary Service Failure" to at least one of our email receivers. We believe this may be related to issues in Amazon US-East-1 region. We're currently trying to work around the issue.
Posted Dec 07, 2021 - 11:47 EST
This incident affected: Snitch Check-in Processing.