Delayed Status Emails
Incident Report for Dead Man's Snitch
Resolved
This incident has been resolved.
Posted 12 months ago. Sep 26, 2016 - 10:37 EDT
Identified
We are experiencing an issue with our email servers. We are aware of the issue, and are working on a fix. Other notification channels are still operational, and delayed emails will be sent once the issue is resolved.
Posted 12 months ago. Sep 26, 2016 - 10:07 EDT