Check-In processing delays and false alarms
Incident Report for Dead Man's Snitch
Resolved
Both deadmanssnitch.com and api.deadmanssnitch.com are back functioning normally. Check-in processing has been moved back to our main hosting provider and everything appears to be stable.
Posted about 2 years ago. Sep 20, 2015 - 13:49 EDT
Update
Both deadmanssnitch.com and api.deadmanssnitch.com are online but with some slowness and intermittent issues.
Posted about 2 years ago. Sep 20, 2015 - 12:09 EDT
Monitoring
We have caught up with our backlog of check-ins and are processing any new ones as they come in. Our alerting system has stabilized though there are current risks with our split between hosting providers. We are actively monitoring the system to ensure alerting continue to be stable.
Posted about 2 years ago. Sep 20, 2015 - 11:16 EDT
Identified
We are processing check-ins again and working through the backlog. We have moved processing to a new provider to get around the current issues with Amazon AWS. The dashboard (https://deadmanssnitch.com) and API are currently offline to due issues at our hosting provider. We are working to stabilize the system.
Posted about 2 years ago. Sep 20, 2015 - 10:45 EDT
Investigating
Check-in processing has stopped again and we are investigating. Our hosting provider is having serious issues this morning that has limited our ability to effectively address the situation.
Posted about 2 years ago. Sep 20, 2015 - 10:09 EDT
Monitoring
We have worked through the backlog of check-ins and have identified that alerts were not sent from 6:45AM EDT until 9AM EDT. The system has stabilized and we are working to get any past due alerts sent.
Posted about 2 years ago. Sep 20, 2015 - 09:55 EDT
Identified
We are currently processing a backlog of check-ins and investigating if the delays have caused any false alerts.
Posted about 2 years ago. Sep 20, 2015 - 09:31 EDT