Issues with Email Check-Ins
Incident Report for Dead Man's Snitch
Resolved
Both Amazon S3 and our email check-in volume has returned to normal. Thank you for your patience.
Posted 7 months ago. Feb 28, 2017 - 20:15 EST
Identified
The major outage at Amazon S3 has also impacted the Simple Email Service (Amazon SES) in US-EAST-1 which we use for receiving emails. We have migrated the receiving of emails to US-WEST-2 to work around the issues. This required a change to DNS which may take some time to propagate to everyone.

Thank you for you patience as we work around this issue. I'm sorry for the confusion that false alerts can cause especially as many of you are dealing with Amazon's issues as well.
Posted 7 months ago. Feb 28, 2017 - 15:39 EST
Investigating
We have been experiencing issues receiving check-ins via email since approximately 17:30 UTC. We are investigating the issue but believe it is related to the ongoing outage with Amazon S3.
Posted 7 months ago. Feb 28, 2017 - 14:59 EST