Email Check-in issues
Incident Report for Dead Man's Snitch
Resolved
Our service provider appears to have caught up on delivery and email check-ins appear to have returned to normal.
Posted over 1 year ago. May 03, 2016 - 12:40 EDT
Identified
Our email service provider has identified an issue with their inbound processing and are working to catch up on a backlog. Email check-ins are catching up and will be arriving delayed from when they occurred.

We recently moved to a new service provider for emails but it appears they may not be able to meet our need for timely delivery and will be reevaluating our options.
Posted over 1 year ago. May 03, 2016 - 11:45 EDT
Investigating
We are currently not receiving email check-ins (check-ins that you send via email). We are investigating. All other systems, including email alerts are functioning fine.
Posted over 1 year ago. May 03, 2016 - 10:34 EDT