The deadmanssnitch.com web portal is inaccessible
Incident Report for Dead Man's Snitch
Resolved
This incident has been resolved.
Posted 12 months ago. Dec 08, 2016 - 21:04 EST
Monitoring
DNS update is propagating and the site is coming back online.
Posted 12 months ago. Dec 08, 2016 - 19:28 EST
Identified
We have tracked down the issue to issues with the DNS record of deadmanssnitch.com and are working on a fix.
Posted 12 months ago. Dec 08, 2016 - 19:21 EST
Investigating
We are investigating into why deadmanssnitch.com is not responding.
Posted 12 months ago. Dec 08, 2016 - 19:14 EST